Get in touch
Back
Resolved

Cloud Migration Progress Report and Availability Analysis

Started 26 Oct at 01:00am HDT.

metadax.com.br
Created

TECHNICAL STATUS REPORT - METADAX
REF: INFRASTRUCTURE MIGRATION (ON-PREMISE TO CLOUD)
REPORT PERIOD: October 20, 2025 to November 18, 2025

SCENARIO SUMMARY
We inform you that, between October 20, 2025 and December 14, 2025, MetaDax is executing the wave migration process of our on-premise servers. to the cloud.

As of the date of this report, we have reached the milestone of 82% of the infrastructure successfully migrated. Our new architecture was designed to be geographically and computationally distributed among the main cloud providers, meeting strict requirements for user location, latency optimization, load balancing, redundancy, and security.

IMPACT ANALYSIS (October 20th to November 18th)
During the migration windows within this period, occasional instabilities were recorded on our status page. It is crucial to highlight the nature of these events:

  • SCOPE: The identified impacts exclusively affected the availability of auxiliary serverless services.

  • RISK: These services were classified as having very low impact and low or zero risk to the core operation.

  • CRITICAL SERVICES: The availability of essential services provided to our clients remained intact and did not suffer negative impacts, as the migration of these components follows an isolated plan.

All reported interruptions in this phase have already been corrected.

NEXT STEPS: MIGRATION OF CRITICAL ENVIRONMENTS
We will soon begin the final migration of critical environments. To ensure business continuity and data security, the following preventive measures are in place:

A) SECURITY AND ROLLBACK: The environments already have full backups, in addition to rollback policies and incident handling plans previously mapped.

B) ACCESS AND REDUNDANCY: Access for clients, suppliers, and partners has already been configured via proxy. In case of instability, a fallback mechanism will be automatically activated.

C) MAINTENANCE WINDOW: The migration of each environment will be performed during low-traffic hours, with adjusted load distribution.

NOTE: During the final switchover, some non-critical information may be temporarily unavailable while the data is synchronized to the new infrastructure.

END OF REPORT
Infrastructure and DevOps Team
METADAX

Posted 26 Oct at 01:00am HDT.